Cannot sync hedgehog in two submaps

Frequent questions asked online, offline, in forums are answered here
Post Reply
GeorgeFlorian
Posts: 5
Joined: Tue Apr 20, 2021 6:21 pm

Cannot sync hedgehog in two submaps

Post by GeorgeFlorian »

I have the Super Starter Set NIA-3D 868/915MHz which contains:
1x Modem HW4.9 915
5x Super Beacon 915-31.0-IMU

I have installed everything from marvelmind_SW_2021_01_31. The tech-support checked this and the install is correct.

I am trying to create two submaps: each for one room. I am following this guide: https://www.youtube.com/watch?v=FXvlDZkxkUU
I have tried syncing the beacon before and after drawing the Service Zone. The result is the same.

The problem is that when I try to make a second submap and sync the hedgehog by pressing the M2 button, the mobile beacon and the orange one start jumping all over the place and it's impossible to sync them.

The beacons placement:
Room1:
Image
Room2:
Image
Screenshots from the dashboard with each individual submap working properly:
Submap0:
Image
Submap1:
Image

Video demonstrating what happens when I activate both submaps at the same time:
https://youtu.be/KYGmzbXNA8w

IMPORTANT: The mobile beacon did not move through the entirety of this experiment.

Map file: https://file.io/IuMuRFjMxETb
I would've attached it to the post, but the forum does not accept .ini files.

nurjan14
Posts: 1
Joined: Fri Jun 25, 2021 12:04 pm

Re: Cannot sync hedgehog in two submaps

Post by nurjan14 »

Hi there,

I didn't look at the map file and your config because one thing just catch my attention. It is the placement of your workspace. What I want to say is that you have got shadow spots where actually rover placed in the video you provided. Because of your desk and monitors and other stuff which is obstructed of line of sight between stationary and mobile beacons. Ideally if you run the same configuration without anything in the room it should work, of course, considering that you got all the rest of the setup right. I have facing with the same problem in my lab trying to get align these zones. Eventually I tried the same way in the ish empty corridor and hall and got not ideally but fairly good tracking.

One way to debug your solution without moving all stuff around is trying to set stationary beacons in such position where it will "hear" (if NIA) the hedge in direct line of sight in any position of the room. Try set them on the wall and try climb to that position try to "see" from the prospective of stationary beacon each position of the room where it can hear in the 1st sub map and small area for handover zone (overlap area with 2nd sub-map) (don't forget about ultrasound and mic pattern in which direction sensors emits and listen) ; find all this possible position from 1st and 2nd stationary beacon; find mutual position for handover zone; build service zone on dashboard, (don't forget to tell to each sub-map with which one it has handover zone by pressing Alt+Left mouse click on the service zone it should appear as dark color), for this mutual position and try move around and align the service zones.

Cheers

Post Reply